pratik
pratik
Error: Error building site: failed to render pages: render of "page" failed: "/pratik_08486b/layouts/now/single.html:6:9": execute of template failed: template: now/single.html:6:9: executing "main" at : error calling first: both limit and seq must be provided I get this error infrequently o... microblog.pratikmhatre.com
|
Embed
manton
manton

@pratik This happens on my blog sometimes too. Haven’t figured it out yet, and it just fixes itself the next run through. Would like to solve it though.

|
Embed
sod
sod

@pratik Which theme, plug-in, or custom theme provides the template now/single.html and is it public somewhere to read?

|
Embed
In reply to
pratik
pratik

@sod I'm using Amit's Musings theme and created the /Now page with @mtt's help. It wasn't part of Amit's theme. The code is here and it generates this Now page.

|
Embed
pratik
pratik

@manton Glad to know I'm not alone. The error will not show for weeks, but on other days, it will show up frequently and above the web timeline. The page renders just fine, so it's mostly to address my OCD of seeing no error messages @sod

|
Embed
pratik
pratik

@manton BTW just noticed that this post doesn't show up in full on the timeline although I put the code in blockquotes and it doesn't exceed 600 chars.

|
Embed
sod
sod

@pratik Thanks. The error is thrown by a line of code that tries to fetch one blog post from the category named now. For some reason, it fails. Instead of getting a list of blog posts to pick the latest one from, Hugo gets nothing and thus throws an error.

Could it have something to do with partial rebuilds, @manton? When Hugo tries to construct Pratik's now page, there are no posts available during build time. Maybe?

|
Embed
manton
manton

@sod @pratik It must be something related to that, yes. I just realized that the page it happens on for me is trying to get posts from a specific category with .Site.Taxonomies.categories.categoryname. So maybe there are no posts for that category at build time.

|
Embed