Micro.blog

manton
manton
Moving to new Hugo manton.org
matti
matti

@manton πŸ₯³ Wohoo! πŸ₯³

ericmwalk
ericmwalk

@manton wow this is great! Seeing how I am using one of the themes you mentioned is already upgraded I am going to take the plunge and do all the upgrades 😁. Probably not said enough but thanks for all your hard work you put into Micro.blog. I am glad I found this place a little over a year ago.

maique
maique

@manton Thank you for the constant updates.

chadgmoore
chadgmoore

@manton so for folks who don’t develop or use many plugins, we should wait? Or is there features we can use sooner rather than later?

issimonwoods
issimonwoods

@manton πŸ™Œ

amit
amit

@manton Brilliant, thank you Manton! There are some functions that are different between these two releases too. I will have to update the Post Stats plug-in too. Also enables a few things that earlier version didn't. So exciting!

BTW how do you recommend handling plug-in versions targeting different Hugo versions?

pimoore
pimoore

@manton Oh wow! πŸŽ‰ Thanks for all your hard work on this, I might have to give Tufte a go on a test site.

manton
manton

@amit Thanks! I haven't thought about how to manage multiple Hugo versions from the same plug-in yet. If Hugo doesn't have something built-in for this, maybe I should just add the version as a param that can be checked in templates?

In reply to
manton
manton

@amit Update: You can get the current Hugo version with {{ .Hugo.Version }}. This will be the full version, e.g. "0.91.2"

amit
amit

@manton Yeah, I think supporting the plug-ins that target different Hugo versions might be tricky. What if someone has an older version of a plug-in installed which works well with 0.54 Hugo versions. But also has a version for 0.91? Hmm.

manton
manton

@amit If it comes to it, we can add a required Hugo version to the plug-in config and Micro.blog can manage it. I don't love that, though, so hopefully it can be avoided.

amit
amit

@manton Nice! This would help to have a single version of plug-in support both Hugo versions. I guess there also needs a way for plug-in to convey what version of Hugo they work with? Via config, maybe? For example, I know Post Stats will fail if someone with 0.91 installs it.

manton
manton

@amit Maybe I need to add an "experimental" disclaimer to the 0.91 option until we have more experience updating plug-ins. πŸ™‚ Let's see how it goes over the next month. It's not going to be the default for a while.

amit
amit

@manton Posted the comment at the same time as yours. I agree, would be good if it can be avoided. But if the config is done right, upgrading Hugo in the backend would be simpler.

sod
sod

@manton Yay! πŸ™Œ I've exposed my plug-ins to the new Hugo version, and everything seems to chug along just fine. Thanks for enabling this.

pimoore
pimoore

@manton Does this new version of Hugo support SASS/SCSS compiling?

manton
manton

@pimoore Yep, it does! I haven't used it myself but @Moondeer confirmed that SCSS works.

Moondeer
Moondeer

@manton @pimoore can confirm

pimoore
pimoore

@Moondeer @manton Oh hell yeah, this changes my development on Hitchens but in a good way.